Pendant mon installation test de SharePoint 2013, j’ai eu une erreur de configuration à l’étape 8.
System.ArgumentException: The SDDL string contains an invalid sid or a sid that cannot be translated.
Parameter name: sddlForm
at System.Security.AccessControl.RawSecurityDescriptor.BinaryFormFromSddlForm(String sddlForm)
at System.Security.AccessControl.RawSecurityDescriptor..ctor(String sddlForm)
at Microsoft.SharePoint.Win32.SPNetApi32.CreateShareSecurityDescriptor(String[] readNames, String[] changeNames, String[] fullControlNames, String& sddl)
at Microsoft.SharePoint.Win32.SPNetApi32.CreateFileShare(String name, String description, String path)
at Microsoft.Office.Server.Search.Administration.AnalyticsAdministration.CreateAnalyticsUNCShare(String dirParentLocation, String shareName)
at Microsoft.Office.Server.Search.Administration.AnalyticsAdministration.ProvisionAnalyticsShare(SearchServiceApplication serviceApplication)

J’avais eu la même erreur précédemment avec SharePoint Foundation preview 2013 mais j’avais passé car tout fonctionnait apparemment sauf le moteur de recherche.
Là, je voulais que tout soit fonctionnel.
Après de brèves recherches j’ai testé et trouvé une solution fonctionnelle sans trop compromettre la sécurité.

La solution est d’aller dans le dossier
“C:\Program Files\Microsoft Office Servers\15.0\Data\Office Server\”
De trouver le dossier “Analytics_”+ guid et de le partager avec « tout le monde » (à vos risques)

Là j’ai pu relancer le products configuration wizard sans aucun soucis.